package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)qt[^cy].*?[^<>\d](\d{3})(?:\D|$)`)
var str = `EKG done this AM with QT 560 and QTC wnl at 535ms, higher than on exam performed 5/3/2015 which showed...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}