package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\w]+|[\w-]+\.+[\w]+)$`)
var str = `user
user.name
user.name123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}