$re = '/^([\w]+|[\w-]+\.+[\w]+)$/m';
$str = 'user
user.name
user.name123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);