const regex = /\b(([A-Z])\w*(?:\s+\w+)*?)\s*\((\2[A-Z]*)\)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(([A-Z])\\w*(?:\\s+\\w+)*?)\\s*\\((\\2[A-Z]*)\\)', 'gmi')
const str = `Some example text (SET) that demonstrates what I'm looking for. Energy system models (ESM) are used to find specific optima (SCO). Some say computer systems (CUST) are cool. In the summer playing outside (OUTS) should be preferred. Stupid example(s) Stupid example(S) Not stupid example (NSEMPLE), bad example (Bexle)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}