$re = '~/\*[^*]*\*+(?:[^/*][^*]*\*+)*/|\b([0-9]+)\b~';
$str = 'For Example
{ 20,100,0X0},/*this line contains 2 integers*/
For Example, my Expression WILL NOT WORK IF
{ 20,100/*new comment 2*/,0X0}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);