import Foundation
let pattern = #"/\*[^*]*\*+(?:[^/*][^*]*\*+)*/|\b([0-9]+)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
For Example
{ 20,100,0X0},/*this line contains 2 integers*/
For Example, my Expression WILL NOT WORK IF
{ 20,100/*new comment 2*/,0X0}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)