using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s*[\{\[]?\%?[\s]*)[\@A-Za-z1-9_\.\s\+\-\*\\]*([\s\*]*=[\s\*\$]*[\{\""]?)[\@A-Za-z1-9_\.\s\+\-\*\\]*(\s*[\}\""]?)([\}\]\%\s]*)";
string input = @"{% set type cookies = ""sugar cookies"" %}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}