const regex = /(\s*[\{\[]?\%?[\s]*)[\@A-Za-z1-9_\.\s\+\-\*\\]*([\s\*]*=[\s\*\$]*[\{\"]?)[\@A-Za-z1-9_\.\s\+\-\*\\]*(\s*[\}\"]?)([\}\]\%\s]*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s*[\\{\\[]?\\%?[\\s]*)[\\@A-Za-z1-9_\\.\\s\\+\\-\\*\\\\]*([\\s\\*]*=[\\s\\*\\$]*[\\{\\"]?)[\\@A-Za-z1-9_\\.\\s\\+\\-\\*\\\\]*(\\s*[\\}\\"]?)([\\}\\]\\%\\s]*)', '')
const str = `{% set type cookies = "sugar cookies" %}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}