package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\+?)[78]+[0-9() -]{16,17}`)
var str = `+7 (495) 965-14-82`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}