import re
regex = re.compile(r"(?:\+?)[78]+[0-9() -]{16,17}")
test_str = "+7 (495) 965-14-82"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")