#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?!(?:0[1]|1[3-7]):\d\d:\d\d).)*((?:0[1]|1[3-7]):\d\d:\d\d)"
Local $sString = "Received: by 127.0.0.1 with SMTP id co5csp22954317qdb; Wed, 6 May 2015 13:02:22 -0700 (PDT) X-Received: by 127.0.0.1 with SMTP id j185mr26699743oig.68.1430928141923; Wed, 06 May 2015 13:02:21 -0700 (PDT)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")