import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^PT(?>(?'hours'\\d+)(?>H))?(?>(?'minutes'\\d+)(?>M))?(?>(?'seconds'\\d+)(?>S))?";
final String string = "PT02M31S\n"
+ "PT01H02M31S\n"
+ "PT22M02S\n"
+ "PT02H22S";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}