re = /^PT(?>(?'hours'\d+)(?>H))?(?>(?'minutes'\d+)(?>M))?(?>(?'seconds'\d+)(?>S))?/m
str = 'PT02M31S
PT01H02M31S
PT22M02S
PT02H22S'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end