package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Error.*"(.*)".*(\d+)`)
var str = `Processing script file: "/Users/johndoe/Projects/test.nsi" (UTF8)
Invalid command: Foo
Error in script "/Users/johndoe/Projects/test.nsi" on line 5 -- aborting creation process`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}