re = /Error.*"(.*)".*(\d+)/
str = 'Processing script file: "/Users/johndoe/Projects/test.nsi" (UTF8)
Invalid command: Foo
Error in script "/Users/johndoe/Projects/test.nsi" on line 5 -- aborting creation process'
# Print the match result
str.match(re) do |match|
puts match.to_s
end