#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<hr\s*\/>\s*[\\n]*\s*(.+<\/p>)"
Local $sString = "<hr />\n\n<h3 class="brown art">Базовая комплектация обычно включает в себя (включая сборку и доставку):</h3>\n<ul>\n <li><em>Сруб из строганного бревна, средний диаметр 25 см. (вершинка).</em></li>\n <li><em>Высота потолков 1 этажа 2.7 м., 2 этажа 2.5-2.7 м.</em></li>\n <li><em>Перегородки по проекту рубленные из такого же бревна, 1 этаж.</em></li>\n <li><em>Тип рубки чаша или лапа (любой).</em></li>\n <li><em>Потолочные и половые балки — лафет 0.15 м.</em></li>\n <li><em>Стропильная система – брус 50x200 мм., через 60 см.</em></li>\n <li><em>Фронтоны крыши зашиваются по каркасу вагонкой.</em></li>\n <li><em>Обрешетка крыши – доска обрезная 25x150 мм.</em></li>\n <li><em>Покрытие крыши рубероидом.</em></li>\n <li><em>Все расходные материалы (лен, скобяные изделия, гидроизоляция фундамента, рубероид).</em></li>\n <li><em>Доставка по Московской области, и др. регионам центральной части РФ (Ярославская, Рязанская, Нижегородская, Тверская, Калужская, Тульская, Владимирская, Ивановская обл. и др. регионы РФ).</em></li>\n <li><em>Разгрузочные работы и сборка на участке заказчика.</em></li>\n</ul>\n<p class="black art">Стоимость базового комплекта сруба под крышу с доставкой, разгрузкой и сборкой:</p>" & @CRLF & _
"<hr />\n\n<h3 class="brown art">Базовая комплектация обычно включает в себя (включая сборку и доставку):</h3>\n<ul>\n <li><em>Сруб из строганного бревна, средний диаметр 25 см. (вершинка).</em></li>\n <li><em>Высота потолков 1 этажа 2.7 м., 2 этажа 2.5-2.7 м.</em></li>\n <li><em>Перегородки по проекту рубленные из такого же бревна, 1 этаж.</em></li>\n <li><em>Тип рубки чаша или лапа (любой).</em></li>\n <li><em>Потолочные и половые балки — лафет 0.15 м.</em></li>\n <li><em>Стропильная система – брус 50x200 мм., через 60 см.</em></li>\n <li><em>Фронтоны крыши зашиваются по каркасу вагонкой.</em></li>\n <li><em>Обрешетка крыши – доска обрезная 25x150 мм.</em></li>\n <li><em>Покрытие крыши рубероидом.</em></li>\n <li><em>Все расходные материалы (лен, скобяные изделия, гидроизоляция фундамента, рубероид).</em></li>\n <li><em>Доставка по Московской области, и др. регионам центральной части РФ (Ярославская, Рязанская, Нижегородская, Тверская, Калужская, Тульская, Владимирская, Ивановская обл. и др. регионы РФ).</em></li>\n <li><em>Разгрузочные работы и сборка на участке заказчика.</em></li>\n</ul>\n<p class="black art">Стоимость базового комплекта сруба под крышу с доставкой, разгрузкой и сборкой:</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")