re = /cat\s+.*\.xml(.*)\[Expert@Arcus-mgmt1\]#\s?/
str = 'cat namedQueries1.xml
<?xml version="1.0" encoding="ISO-8859-1" ?>
<NamedQueriesConfiguration xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="NamedCloudQueries.xsd">
<NamedQuery>
<Name>SC2</Name>
<RequestedInformation>AssignedIP</RequestedInformation>
<Constraint>
<FieldName>VdcName</FieldName>
<Operator>Equals</Operator>
<Value>SC2</Value>
</Constraint>
</NamedQuery>
<NamedQuery>
<Name>SC1</Name>
<RequestedInformation>AssignedIP</RequestedInformation>
<Constraint>
<FieldName>VdcName</FieldName>
<Operator>Equals</Operator>
<Value>SC1</Value>
</Constraint>
</NamedQuery>
</NamedQueriesConfiguration>[Expert@Arcus-mgmt1]#'
# Print the match result
str.match(re) do |match|
puts match.to_s
end