# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!animations|foreach|completion|block|dispatch|configuration|mas_makeConstraints|dispatchUI):\s*(\^(?!\))[^{;]*\{\s+(?!\s*@strongify\(self)[^{}]*?\b(?:self|_)(?!\s+class))/\1,/gm;t' <<< " [[RACObserve(self, model) ignore:nil] subscribeNext: ^(id value) {
// UI配置
@strongify(self);
MyBarModel *myBarModel = (MyBarModel*) value;
[self.imgBar sd_setImageWithURL:[NSURL URLWithString:myBarModel.barImgUrl]
placeholderImage:[UIImage imageNamed:@\"logo-bar\"]];
self.lblBarTitle.text = myBarModel.barName;
self.lblBarDescription.text = myBarModel.barDesc;
self.barDescriptionTextField.text = myBarModel.barDesc;
self.cellType = DDMyInstallBarCellTypeFinish;
}];"