use strict;
my $str = ' [[RACObserve(self, model) ignore:nil] subscribeNext: ^(id value) {
// UI配置
@strongify(self);
MyBarModel *myBarModel = (MyBarModel*) value;
[self.imgBar sd_setImageWithURL:[NSURL URLWithString:myBarModel.barImgUrl]
placeholderImage:[UIImage imageNamed:@"logo-bar"]];
self.lblBarTitle.text = myBarModel.barName;
self.lblBarDescription.text = myBarModel.barDesc;
self.barDescriptionTextField.text = myBarModel.barDesc;
self.cellType = DDMyInstallBarCellTypeFinish;
}];';
my $regex = qr/(?<!animations|foreach|completion|block|dispatch|configuration|mas_makeConstraints|dispatchUI):\s*(\^(?!\))[^{;]*\{\s+(?!\s*@strongify\(self)[^{}]*?\b(?:self|_)(?!\s+class))/mp;
my $subst = '\\1,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";