package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S*(?:\S\s*){1,9}$`)
var str = `thisHُ is a long string I cant display`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}