$re = '/\S*(?:\S\s*){1,9}$/m';
$str = 'thisHُ is a long string I cant display';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);