import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(count)\\s+\"[^\"]+\"\\s*((tsr|sum)\\s+(<|<<)\\s+(\"[^\"]+\"|[-+]?[0-9]*\\.?[0-9]+))?\\s*$";
final String string = "count hede";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}