import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*osf=(\\S+?)[;|\\s].*$";
final String string = "osf=5633d9e768732dc8c7ca1f9a._7iTy0uvL_4eVBf_y_SzRVEeOII; csrftoken=ah8zV0tSZSx9nnmkMqOKaUARdWC2OTWs\n\n"
+ "asdf=asdfasdf; osf=5633d9e768732dc8c7ca1f9a._7iTy0uvL_4eVBf_y_SzRVEeOII; csrftoken=ah8zV0tSZSx9nnmkMqOKaUARdWC2OTWs\n\n"
+ "asfdasdf=asdfasdf; osf=5633d9e768732dc8c7ca1f9a._7iTy0uvL_4eVBf_y_SzRVEeOII\n\n"
+ "osf=5633d9e768732dc8c7ca1f9a._7iTy0uvL_4eVBf_y_SzRVEeOII\n";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}