import re
regex = re.compile(r"^.*osf=(\S+?)[;|\s].*$", flags=re.MULTILINE)
test_str = ("osf=5633d9e768732dc8c7ca1f9a._7iTy0uvL_4eVBf_y_SzRVEeOII; csrftoken=ah8zV0tSZSx9nnmkMqOKaUARdWC2OTWs\n\n"
"asdf=asdfasdf; osf=5633d9e768732dc8c7ca1f9a._7iTy0uvL_4eVBf_y_SzRVEeOII; csrftoken=ah8zV0tSZSx9nnmkMqOKaUARdWC2OTWs\n\n"
"asfdasdf=asdfasdf; osf=5633d9e768732dc8c7ca1f9a._7iTy0uvL_4eVBf_y_SzRVEeOII\n\n"
"osf=5633d9e768732dc8c7ca1f9a._7iTy0uvL_4eVBf_y_SzRVEeOII\n")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)