#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?:" & @CRLF & _
" (\((?>[^()]|(?1))*\)) # Match (..(.)) like substrings" & @CRLF & _
" |" & @CRLF & _
" ({(?>[^{}]|(?2))*}) # Match {{.}..} like substrings" & @CRLF & _
")" & @CRLF & _
"(*SKIP)(*F) # Ignore the texts matched" & @CRLF & _
"|" & @CRLF & _
"(?:FIRSTNAME|LASTNAME|PHONE|EMAIL)"
Local $sString = "FIRSTNAME LASTNAME PHONE EMAIL {FIRSTNAME LASTNAME PHONE EMAIL{FIRSTNAME LASTNAME PHONE EMAIL }FIRSTNAME LASTNAME PHONE EMAIL }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")