import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\n"
+ " (\\((?>[^()]|(?1))*\\)) # Match (..(.)) like substrings\n"
+ " |\n"
+ " (\\{(?>[^\\{\\}]|(?2))*\\}) # Match \\{\\{.\\}..\\} like substrings\n"
+ ")\n"
+ "(*SKIP)(*F) # Ignore the texts matched\n"
+ "|\n"
+ "(?:FIRSTNAME|LASTNAME|PHONE|EMAIL)";
final String string = "FIRSTNAME LASTNAME PHONE EMAIL {FIRSTNAME LASTNAME PHONE EMAIL{FIRSTNAME LASTNAME PHONE EMAIL }FIRSTNAME LASTNAME PHONE EMAIL }";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}