const regex = /(\d)(?!\1)(\d)(\1\2|\2\1)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d)(?!\\1)(\\d)(\\1\\2|\\2\\1)', 'mg')
const str = `2323
4545
9898
4444
5555
1221`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}