$re = '/(\d)(?!\1)(\d)(\1\2|\2\1)/m';
$str = '2323
4545
9898
4444
5555
1221';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);