using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<DOCUMENT>([\s\S]*?)<\/DOCUMENT>";
string input = @"ABCDE<DOCUMENT>
Lorem ipsum
dolor sit amet</DOCUMENT>
EFGHIJK.";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}