$re = '/<DOCUMENT>([\s\S]*?)<\/DOCUMENT>/s';
$str = 'ABCDE<DOCUMENT>
Lorem ipsum
dolor sit amet</DOCUMENT>
EFGHIJK.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);