use strict;
my $str = 'Some-string string here!';
my $regex = qr/[^\p{M}\p{L}]+/up;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";