// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\pL_][\pL_\pNd]*$").unwrap();
let string = "functionName
functionName_
_function_name
__constant__
__00000____
__________
var_name
ClassName
ClassName0
0functionName
function000Name
-varname
@varname
Class-Name";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}