#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[2-9][0-9]{2}$)|(^[1-2][0-9]{3}$)"
Local $sString = "1" & @CRLF & _
"12" & @CRLF & _
"19" & @CRLF & _
"20" & @CRLF & _
"21" & @CRLF & _
"29" & @CRLF & _
"30" & @CRLF & _
"31" & @CRLF & _
"40" & @CRLF & _
"50" & @CRLF & _
"60" & @CRLF & _
"70" & @CRLF & _
"80" & @CRLF & _
"98" & @CRLF & _
"99" & @CRLF & _
"100" & @CRLF & _
"101" & @CRLF & _
"102" & @CRLF & _
"149" & @CRLF & _
"150" & @CRLF & _
"180" & @CRLF & _
"190" & @CRLF & _
"199" & @CRLF & _
"200" & @CRLF & _
"201" & @CRLF & _
"202" & @CRLF & _
"300" & @CRLF & _
"400" & @CRLF & _
"500" & @CRLF & _
"600" & @CRLF & _
"999" & @CRLF & _
"1000" & @CRLF & _
"1001" & @CRLF & _
"1002" & @CRLF & _
"2000" & @CRLF & _
"3000" & @CRLF & _
"9999" & @CRLF & _
"10000" & @CRLF & _
"10001" & @CRLF & _
"10002" & @CRLF & _
"10003" & @CRLF & _
"19999" & @CRLF & _
"20000" & @CRLF & _
"20001" & @CRLF & _
"20002" & @CRLF & _
"30000" & @CRLF & _
"50000" & @CRLF & _
"60000" & @CRLF & _
"99999" & @CRLF & _
"100000" & @CRLF & _
"100001" & @CRLF & _
"30000000" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")