using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[2-9][0-9]{2}$)|(^[1-2][0-9]{3}$)";
string input = @"1
12
19
20
21
29
30
31
40
50
60
70
80
98
99
100
101
102
149
150
180
190
199
200
201
202
300
400
500
600
999
1000
1001
1002
2000
3000
9999
10000
10001
10002
10003
19999
20000
20001
20002
30000
50000
60000
99999
100000
100001
30000000
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}