using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=([A-Z]{(?:[^{}]|(?1))+}))";
string input = @"tes{}tR{R{abc}aD{mnoR{xyz}}}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}