$re = '/(?=([A-Z]{(?:[^{}]|(?1))+}))/';
$str = 'tes{}tR{R{abc}aD{mnoR{xyz}}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);