import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|\\s)(#+)([^#\\s]*[^#\\\\])(\\2)(?=\\s)";
final String string = "#foobar# - обрамлять, \n"
+ "###foobar### - обрамлять, \n"
+ "#foobar### - не обрамлять(выводить решетки), \n"
+ "\\#foobar\\# - не обрамлять(выводить решетки), \n"
+ "\\#foobar\\### - не обрамлять(выводить решетки),\n\n"
+ "#foobar\\# - не обрамляет,\n"
+ "#\\# - не обрамляет";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}