$re = '/(^|\s)(#+)([^#\s]*[^#\\\\])(\2)(?=\s)/';
$str = '#foobar# - обрамлять,
###foobar### - обрамлять,
#foobar### - не обрамлять(выводить решетки),
\\#foobar\\# - не обрамлять(выводить решетки),
\\#foobar\\### - не обрамлять(выводить решетки),
#foobar\\# - не обрамляет,
#\\# - не обрамляет';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);