package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\S+-(?:a|b)\b`)
var str = `eu-a us-b eu-c eu-b us-a us-a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}