$re = '/\b\S+-(?:a|b)\b/';
$str = 'eu-a us-b eu-c eu-b us-a us-a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);