$re = '/\w+(?:\s*\|\s*\w+)+/m';
$str = 'str|int|bool
Optional[int|tuple[str|int]]
dict[str | int, list[B | C | Optional[D]]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);