package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z]{6}[0-9]{2}[A-Za-z]{1}[0-9]{2}[A-Za-z]{1}[0-9]{3}[A-Za-z]{1}$`)
var str = `CRCGTN82B03G015F`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}