re = /^[A-Za-z]{6}[0-9]{2}[A-Za-z]{1}[0-9]{2}[A-Za-z]{1}[0-9]{3}[A-Za-z]{1}$/m
str = 'CRCGTN82B03G015F'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end