import re
regex = re.compile(r"\(\s+(.*?)\s+\)", flags=re.MULTILINE)
test_str = "foo( a )"
subst = "($1)"
result = regex.sub(subst, test_str)
if result:
print(result)