package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:Etu|pro|-)(?:\w{0:9}|\s)
`)
var str = `Eturauhasen koko : 34`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}