$re = '/(?:Etu|pro|-)(?:\w{0:9}|\s)
/';
$str = 'Eturauhasen koko : 34';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);