package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(.+)\]`)
var str = `Примерный текст, примерный текст, примерный текст, примерный текст. [id123456|Пользователь].
Ещё текст, примерный текст, примерный текст, примерный текст, примерный текст [club987654321|Сообщество] , примерный текст, примерный текст, примерный текст.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}