re = /\[(.+)\]/
str = 'Примерный текст, примерный текст, примерный текст, примерный текст. [id123456|Пользователь].
Ещё текст, примерный текст, примерный текст, примерный текст, примерный текст [club987654321|Сообщество] , примерный текст, примерный текст, примерный текст.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end