const regex = /^(979-1[0-2]|978-[0-7])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(979-1[0-2]|978-[0-7])$', 'gm')
const str = `978-5
979-10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}