$re = '/^(979-1[0-2]|978-[0-7])$/m';
$str = '978-5
979-10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);